Skip to main content
Pentaho Documentation

Access Spoon

Overview

How to access Spoon.

grStepGraphicDIConfigAccessSpoon.png

Spoon is a desktop application that you will use primarily as a graphical interface and editor for transformations and jobs. With Spoon you can author, edit, run, and debug transformations and jobs. You can also use Spoon to enter license keys, add data connections, and define security.

When you are done, please go on to the next stop on the Guide Post graphic.

Start Spoon

There are a few different ways to start Spoon. The method that you should use depends on the way you installed Pentaho Data Integration (PDI).

Start Spoon for Windows Pentaho Graphical Installation

  1. Start the DI server.
  2. From the Windows Start menu, select All Programs > Pentaho Enterprise Edition > Design Tools > Data Integration. The PDI Design Tool, Spoon, appears.

Start Spoon for Archive or Manual Installation

  1. Start the DI server.
  2. Navigate to the folder where you have installed PDI. For example ...\pentaho\design-tools\data-integration.
  3. Launch Spoon in the best way for your operating system.
    1. For Windows: double-click Spoon.bat.
    2. For Linux: double-click spoon.sh
    3. For Macintosh: go to .../pdi-ee/data-integration and double click on the Data Integration 32-bit or Data Integration 64-bit icon depending on your system.
    The Pentaho License Manager dialog appears. You must enter licenses.

Tour Spoon

File:/SpoonExportPNG.png

Component Name Name Function
File:/grCallout1.png Toolbar Single-click access to common actions such as create a new file, opening existing documents, save and save as.
File:/grCallout2.png Perspectives Toolbar Switch between the different perspectives.
  • Data Integration — Create ETL transformations and jobs
  • Instaview — Use pre-made templates to create visualizations from PDI transformations
  • Visualize — Test reporting and OLAP metadata models created in the Model perspective using the Report Design Wizard and Analyzer clients
  • Model Editor — Design reporting and OLAP metadata models which can be tested right from within the Visualization perspective or published to the Pentaho BA Server
  • Schedule — Manage scheduled ETL activities on the Data Integration Server
File:/grCallout3.png Sub-toolbar Provides buttons for quick access to common actions specific to the transformation or job such as Run, Preview, and Debug.
File:/grCallout4.png Design and View Tabs

The Design tab of the Explore pane provides an organized list of transformation steps or job entries used to build transformations and jobs. Transformations are created by simply dragging transformation steps from the Design tab onto the canvas and connecting them with hops to describe the flow of data.

The View tab of the Explore pane shows information for each job or transformation. This includes information such as available database connections and which steps and hops are used.

In the image, the Design tab is selected.

File:/grCallout5.png Canvas Main design area for building transformations and jobs describing the ETL activities you want to perform

 

Table 1. Spoon Icon Descriptions
Icon Description
File:/new_job_transform.png Create a new job or transformation
File:/open_transformation.png Open transformation/job from file if you are not connected to a repository or from the repository if you are connected to one
File:/explore_repo.png Explore the repository
File:/save.png Save the transformation/job to a file or to the repository
File:/save_file.png Save the transformation/job under a different name or file name (Save as)
File:/run_transform.png Run transformation/job; runs the current transformation from XML file or repository
File:/pause.png Pause transformation
File:/stop.png Stop transformation
File:/preview.png Preview transformation: runs the current transformation from memory. You can preview the rows that are produced by selected steps.
File:/debug.png Run the transformation in debug mode; allows you to troubleshoot execution errors
File:/replay.png Replay the processing of a transformation
File:/verify.png Verify transformation
File:/impact_analysis.png Run an impact analysis on the database
File:/gen_sql.png Generate the SQL that is needed to run the loaded transformation.
File:/launch_db_explorer.png Launch the database explorer allowing you to preview data, run SQL queries, generate DDL and more
File:/hide_execution.png Hide execution results pane
File:/lock_transformation.png Lock transformation

Enter Licenses

You must start Spoon before adding licenses.
  1. Copy your license files to a convenient location.
  2. Log into Spoon. The Pentaho License Manager dialog appears.
  3. From within the Pentaho License Manager, click on the Add button.
  4. Double-click on the license key to open it. A green check appears in the Status column to show that the license key installed correctly.
  5. Click Close to close the dialog box.
  6. Close any windows that appear and restart Spoon so that the license key will take effect.

Connect to the DI Repository

The DI Repository provides you a place to centrally store ETL jobs and transformations. You may choose to set up common connections for your users now or you can close the dialog box and allow your users to connect to the DI Repository themselves.

  1. Start Spoon.
  2. Select Tools > Repository > Connect.
  3. In the Repository Connection dialog box, click the add button.
  4. Select DI Repository: DI Repository and click OK. The Repository Configuration dialog box appears.
  5. Keep the default URL, which is http://localhost:9080/pentaho-di.
  6. Click Test to ensure your connection is properly configured. If you get an error, make sure you have started the DI Server.
  7. Click OK to exit the Success dialog box.
  8. Enter an ID and Name for your repository.
  9. Click OK to exit the Repository Configuration dialog box. Your new connection appears in the list of available repositories.
  10. Log on to the repository by entering the following credentials: user name = admin, password = password.

If you want the Repository Connection window to automatically appear when Spoon starts, go to Tools > Options and click Show repository dialog at startup.

Change the Administrator Password

After you have logged into Spoon for the first time, it is a best practice to change the default administrator password.