Skip to main content
Pentaho Documentation

DI Migration Introduction

Overview

Introduction to the DI Migrator Guide.

This section explains how to migrate version 4.4.x of the Pentaho Data Integration (DI) Server, plugins, and design tools to version 5.x.x

Note: To migrate the Pentaho Business Analytics (BA) Server, plugins, and design tools see Migrate BA Systems.

We recommend that you read through all migration documentation before you perform tasks.  Familiarity with the entire process can help you plan your strategy and increase the likelihood of a successful migration experience. If you need assistance with the migration process, contact Technical Support. If you have need additional help tailoring the migration process for your environment, contact Concierge or Consulting Services.

Note: If you have a pre-4.4.x version of DI Server and you want to migrate to version 5.x.x, you must do so incrementally, version by version, until you reach version 4.4.x.  Upgrade instructions appear in the documentation for each version of the software.  After you have upgraded to version 4.4.x, you can use these instructions to migrate to version 5.x.x.

Prerequisites

You need a working version of DI Server version 4.4.x.

Expertise

The topics in this section are written for IT administrators who know where data is stored, how to connect to it, details about the computing environment, and how to use the command line to issue commands for Microsoft Windows or Linux. You also need the appropriate accesses and permissions to install and migrate software.

Tools

You need these tools to perform migration tasks.

  • Pentaho-supplied Migration Tool. Instructions for how to obtain this tool appear in the Prepare Environment section.
  • File Difference tool of your choice.
  • Zip or Archive tool of your choice.
  • Text editor of your choice.
  • (Optional) Software to take a "snapshot" or "image" of the DI Server before you run the Migration Tool.
Note: These instructions are only for Enterprise Edition upgrades. You cannot upgrade a PDI 4.4.x Community Edition deployment to PDI 5.x.x Enterprise Edition with this process.

Login Credentials

You need access to an account that has administrative privileges. Additionally, Linux users might need to use the root account for some tasks.