Skip to main content
Pentaho Documentation

Working with Jobs

Overview

Explains how to create, save, and run a job.

This section explains how to create, save, and run a job.  See Getting Started with PDI for a comprehensive, "real world" exercise for creating, running, and scheduling jobs and jobs.

Create a Job

Follow these instructions to create your job.

  1. Click File > New > Job or hold down the CTRL+ALT+N keys.
  2. Go to the Design tab.  Expand the folders or use the Entries field to search for specific entries.  
  3. Either drag the entry to the Spoon canvas or double-click it.  
  4. Double-click the entry to open its properties window.  For help on filling out the window, click the Help button that is available in each entry.
  5. To add another entry, either drag the step to the Spoon canvas or double-click it.  
  • If you dragged the entry to the canvas, you can add a hop by pressing the SHIFT key and drawing a hop from one entry to the other. 
  • If you double-click it, the entry appears on the canvas with a hop already connected to your previous entry.  
  1. When finished, save the job.

Adjust Job Properties

You can adjust the parameters, logging options, settings, and transactions for jobs.  To view the job properties, click CTRL+J or  right-click on the canvas and select Job settings from the menu that appears.

JobProperties2.png

Save a Job Locally

Follow these instructions to save a job locally on your file system.

  1. In Spoon, select File > Save.
  2. Enter the job name in the Save As window and select the location.
  3. Click OK.  The job is saved.

Save a Job Remotely

Follow these instructions to save a job remotely on the DI Server.

  1. Connect to a repository.
  2. In Spoon, click File > Save As. The Job Properties window appears.
  3. In the Job Name field, enter the job name.
  4. In the Directory field, click the Folder Icon to select a repository folder where you will save your job.
  5. Click OK to exit the Job Properties window. The Enter Comment window appears.
  6. Enter a comment, then click OK.  The job is saved.

Open a Job

Follow these instructions to open a job.

  1. In Spoon, select File > Open.
  2. If you are opening a file from the repository, select the file from the Select a Repository Object window, then click OK.  Otherwise, select the file from the Open window, then click OK.
  3. The job appears on the canvas.

If you get a message indicating that a plugin is missing, see the Fix Transformation and Job Problems section for more details.

Using the Job Menu

Right-click the job's canvas to see the job menu.  Items and descriptions follow.

Menu Item Description
New Hop Creates a new hop.
Open Referenced Object Opens referenced transformations.
Edit ... Shows the configuration window for the step or transformation.
Description ... Allows you to add a description to the step.
Copy Copies selected items to the clipboard.
Duplicate Makes a copy of the selected items, then pastes them to the canvas.
Delete Deletes selected items from the canvas.
Hide Hides the step or entry from the Spoon canvas.  Caution: if you hide the step or entry, you will need to open the transformation or job XML file and hand edit it to view it again.  For more details, see the troubleshooting section.
Detach Detach the step or entry from the transformation or job.
Align/Distribute Arranges steps or entries on the canvas so that they are aligned properly or distributed evenly.  This helps create a visually pleasing transformation or job that is easier to read and digest.

Align refers to where the steps or entries are permitted along the x (horizontal) or y (vertical) axis.   Distribute makes the horizontal and vertical spacing between steps or entries consistent.   Typically, you turn on the grid, then move the different steps or entries on the canvas so that they form some sort of pattern, like a straight or branching line.  Then you select steps or entries and apply the following options as needed.

  • Align Left - Positions all steps or entries so their left sides start on the same "x" (horizontal) coordinate as the left-most step or entry.  After applied, steps or entries are arranged in a straight vertical line.  No changes are made to the spaces between steps or entries.
  • Align Right -  Positions all steps or entries so their right sides start on the same "x" (horizontal) coordinate as the right-most step or entry.  After applied, steps or entries are arranged in a straight vertical line.  No changes are made to the spaces between steps or entries.
  • Align Top-  Positions all steps or entries so their top sides start on the same "y" (horizontal) coordinate as the step or entry positioned closest to the top of the canvas.  After applied, steps or entries are arranged in a straight horizontal line. No changes are made to the spaces between steps or entries.
  • Align Bottom-  Positions all steps or entries so their bottom sides start on the same "y" (horizontal) coordinate as the step or entry positioned closest to the bottom of the canvas.  After applied, steps or entries are arranged in a straight horizontal line. No changes are made to the spaces between steps or entries.
  • Distribute Horizontally - Positions all steps or entries so that they are evenly spaced horizontally.  After applied, steps or entries are arranged evenly.  No changes are made to the alignment.
  • Distribute Vertically - Positions all steps or entries so that they are evenly spaced vertically.  After applied, steps or entries are arranged evenly. No changes are made to the alignment.
  • Snap to Grid - Aligns steps or entries on the canvas to the grid.  If grid markers do not appear on the canvas, select Tools > Options > Look & Feel > Show Canvas Grid.  See the Customize Spoon Options  for more information on how to  customize Spoon.
Restartable Checkpoint Checkpoints let you restart jobs that fail without you having to rerun the entire job from the beginning.  You add checkpoints at hops that connect one job entry to another.  Checkpoints are addressed in detail in the Use Checkpoints to Restart Jobs topic.
Run Next Entries in Parallel Allows you to launch job entries in parallel.  Use this to run jobs in parallel on the same machine or remotely. 

Model

Generates a model of the data in your transformation.  The data should have a dimension or a measure.  Right-click on a step or entry that has data that can be modeled, such as the Table Output step.  The data appears in Pentaho Metadata Editor.
Visualize Generates a visualization of the data in your transformation.  Right-click on a step or entry that has data that can be visualized, such as the Table Output step.   Two sub-options appear when this menu option is selected:
  • Analyzer - Visualizes the data in Analyzer, which is an analytic visualization tool that allows you to filter and drill down into your data.  For more information on Analyzer, see Get Started with Analyzer Reports and Use Pentaho Analyzer.
  • Report Wizard - Starts the Report Design Wizard, which configures a visualization of the data in Pentaho Report Designer.  Report Designer is a report creation tool that allows you to create highly detailed, print-quality reports.  For more information on Pentaho Report Designer, see Getting Started with Report Designer and Design Print-Quality Reports with Report Designer.

Run a Job

When you are done modifying a job, you can run it by clicking the Run button from the main menu toolbar, or by pressing F9. There are three options that allow you to decide where you want your job to be executed:

  • Local Execution — The job executes on the machine you are currently using.
  • Execute remotely — Allows you to specify a remote server where you want the execution to take place. This feature requires that you have the Data Integration Server running or Data Integration installed on a remote machine and running the Carte service. To use remote execution you first must set up a slave server (see Use Carte Clusters to Run Transformations and Jobs) .
  • Execute clustered — Allows you to execute a job in a clustered environment.