Skip to main content
Pentaho Documentation

Create a Report with Report Designer

Follow the instructions below to begin creating your report:
  1. Start the Report Designer. Go to Start > Programs > Pentaho Enterprise Edition > Design Tools > Report Designer. The Report Designer home page appears.
  2. Click New Report in the Welcome dialog box. The design workspace appears.
    Note: If you'd like to change the size of the layout bands to give yourself more area to work in without changing the dimensions of the published report, you can click and drag the percentage number in the upper left corner of the workspace. By default it says 100%, but if you click and drag it diagonally toward the upper left or lower right corners, the view will zoom in or out. If you want to reset the view to 100%, double-click the upper left corner where the percentage shows.
  3. In the right pane, click the Data tab.
  4. For the purpose of this exercise, right-click Data Sets and choose JDBC. Alternatively, you can click the yellow database icon to display the JDBC dialog box. The JDBC Data Source dialog box appears.
  5. Under Connections, select SampleData (Memory).
  6. Next to Available Queries click the Add icon. Query 1 appears under Available Queries. Notice that the Edit icon is enabled.

    File:/rd_2.png

  7. Click the Edit icon. The SQL Query Designer window opens. The SQL Query Designer provides you with a graphical environment that allows you to work with the data even if you don't understand SQL, the standard programming language for retrieving content from databases.
  8. Double-click ORDERFACT so that the table appears in the workspace as shown in the image above.
  9. In the SQL Query Designer workspace, right-click "ORDERFACT" and choose deselect all. File:/rd_6.png
  10. Now, select the following fields in the ORDERFACT table: ORDERNUMBER, QUANTITYORDERED, PRICEEACH, and ORDERDATE.

File:/rd_7.png

  1. Double-click PRODUCTS so that the table appears in the workspace. Notice that there is a line that joins the ORDERFACT and PRODUCTS tables together.
  2. Deselect all PRODUCTS table fields, except for PRODUCTNAME and PRODUCTLINE. File:/rd_8.png
  3. For the purpose of this exercise, click the Syntax tab in the lower left portion of the SQL Query Designer workspace to display a simple SQL statement associated with the tables. Notice that PRODUCTCODE is the common field between the ORDERFACT and PRODUCTS tables. File:/rd_9.png
  4. Click OK in the syntax window to return to the JDBC Data Source dialog box. Notice that the SQL statement appears on the right under Query.
  5. In the JDBC Data Source dialog box, click OK to return to the Design page. Notice that the fields associated with your tables are listed under Query 1. You are now ready to start designing your report.

    File:/rd_10.png