Skip to main content
Pentaho Documentation

Access Spoon

Overview

How to access Spoon.

Spoon is a desktop application that you will use primarily as a graphical interface and editor for transformations and jobs. With Spoon you can author, edit, run, and debug transformations and jobs. You can also use Spoon to enter license keys, add data connections, and define security.

Start Spoon

There are a few different ways to start Spoon. The method that you should use depends on the way you installed Pentaho Data Integration (PDI).

Start Spoon for Windows Pentaho Graphical Installation

  1. Start the DI server.
  2. From the Windows Start menu, select All Programs > Pentaho Enterprise Edition > Design Tools > Data Integration. The PDI Design Tool, Spoon, appears.

Start Spoon for Archive or Manual Installation

  1. Start the DI server.
  2. Navigate to the folder where you have installed PDI. For example ...\pentaho\design-tools\data-integration.
  3. Launch Spoon in the best way for your operating system.
    1. For Windows: double-click Spoon.bat.
    2. For Linux: double-click spoon.sh
    3. For Macintosh: go to .../pdi-ee/data-integration and double click on Data Integration icon.
    The Pentaho License Manager dialog appears. You must enter licenses.

Data Integration Perspective

The Data Integration interfaces allows you to create transformations, jobs, and more.

Component Name Description
File:/grCallout1.png Toolbar Single-click access to common actions such as create a new file, opening existing documents, save and save as.
File:/grCallout2.png Perspectives Menu Switch between the different perspectives.
  • Data Integration — Create ETL transformations and jobs
  • Model Editor — Design reporting and OLAP metadata models which can be tested right from within the Visualization perspective or published to the Pentaho BA Server
  • Schedule — Manage scheduled ETL activities on the Data Integration Server
  • Visualize — Test reporting and OLAP metadata models created in the Model perspective using the Report Design Wizard and Analyzer clients
File:/grCallout3.png Sub-toolbar Provides buttons for quick access to common actions specific to the transformation or job such as Run, Preview, and Debug.
File:/grCallout4.png Design and View Tabs

The Design tab of the Explore pane provides an organized list of transformation steps or job entries used to build transformations and jobs. Transformations are created by simply dragging transformation steps from the Design tab onto the canvas and connecting them with hops to describe the flow of data.

The View tab of the Explore pane shows information for each job or transformation. This includes information such as available database connections and which steps and hops are used.

In the image, the Design tab is selected.

File:/grCallout5.png Canvas Main design area for building transformations and jobs describing the ETL activities you want to perform
Table 1. Spoon Icon Descriptions
Icon Description
new.png Create a new job or transformation
open.png Open transformation/job from file if you are not connected to a repository or from the repository if you are connected to one
exploreRepo.png Explore the repository
save.png Save the transformation/job to a file or to the repository
saveas.png Save the transformation/job under a different name or file name (Save as)

Run transformation/job and set run options; runs the current transformation from XML file or repository
pause.png Pause transformation
stop.png Stop transformation
preview.png Preview transformation: runs the current transformation from memory. You can preview the rows that are produced by selected steps.
debug.png Run the transformation in debug mode; allows you to troubleshoot execution errors
replay.png Replay the processing of a transformation
check.png Verify transformation
impact.png Run an impact analysis on the database
SQLbutton.png Generate the SQL that is needed to run the loaded transformation.
exploredb.png Launch the database explorer allowing you to preview data, run SQL queries, generate DDL and more
show-results.png Show execution results pane
lock.png Lock transformation

Enter Licenses

You must start Spoon before adding licenses.
  1. Copy your license files to a convenient location.
  2. Log into Spoon. The Pentaho License Manager dialog appears.
  3. From within the Pentaho License Manager, click on the Add button.
  4. Double-click on the license key to open it. A green check appears in the Status column to show that the license key installed correctly.
  5. Click Close to close the dialog box.
  6. Close any windows that appear and restart Spoon so that the license key will take effect.

Connect to the Pentaho Repository

The Pentaho Repository provides you a place to centrally store ETL jobs and transformations. You may choose to set up common connections for your users now or you can close the dialog box and allow your users to connect to the Pentaho Repository themselves.

  1. Start Spoon.
  2. Select Tools > Repository > Connect.
  3. In the Repository Connection dialog box, click the add button.
  4. Select Pentaho Repository (Recommended) and click OK. The Repository Configuration dialog box appears.
  5. Keep the default URL, which is http://localhost:9080/pentaho-di.
  6. Click Test to ensure your connection is properly configured. If you get an error, make sure you have started the DI Server.
  7. Click OK to exit the Success dialog box.
  8. Enter an ID and Name for your repository.
  9. Click OK to exit the Repository Configuration dialog box. Your new connection appears in the list of available repositories.
  10. Log on to the repository by entering the following credentials: user name = admin, password = password.

If you want the Repository Connection window to automatically appear when Spoon starts, go to Tools > Options and click Show repository dialog at startup.

Change the Administrator Password

After you have logged into Spoon for the first time, it is a best practice to change the default administrator password.