Skip to main content
Pentaho Documentation

Publish Your Report

You have created and formatted a simple report, added a chart, and now you are ready to share the report with your users.

  1. In the Report Designer, click File > Open to open the report you just created.
  2. Click File > Publish. Alternatively, click File:/rd_publish.png. If you have not saved the report, a warning message reminds you to save it. The Login dialog box appears, pre-populated with credentials valid for the evaluation. Make sure that the server's URL is set to http://localhost:8080/pentaho/.

    File:/rd_33.png

  3. Click OK. The Publish to Server dialog box appears.
  4. In the dialog box, type in a report name and description into the appropriate fields.
  5. Under Location, save the report in the .../steel-wheels/reports folder.
  6. Select html as the Output Type and click OK. A success message appears.
  7. Click Yes to go directly to the User Console to view the report you just published. If you want to access the report later, log on to the Pentaho Server by going to http:// localhost:8080 in your Web browser, then navigate to the Reporting Examples directory in the Solution Browser. You should see your published report in the list. If not, click Tools > Refresh Repository.
  8. Log on as Admin. The default admin password is password.
  9. Your report displays in the User Console. You now have a report that users can view at any time.

    File:/order_report.png

  10. In the User Console select your product line parameter from the drop-down list. Accept the default under Output Type.