Skip to main content
Pentaho Documentation

Create a Report with Report Designer

Follow the instructions below to begin creating your report:

  1. Start the Report Designer. Go to Start > Programs > Pentaho Enterprise Edition > Design Tools > Report Designer. The Report Designer home page appears.
  2. Click New Report in the Welcome dialog box. The design workspace appears.

    If you would like to change the size of the layout bands to give yourself more area to work in without changing the dimensions of the published report, you can click and drag the percentage number in the upper left corner of the workspace. By default it says 100%, but if you click and drag it diagonally toward the upper left or lower right corners, the view will zoom in or out. If you want to reset the view to 100%, double-click the upper left corner where the percentage shows.

  3. In the right pane, click the Data tab.
  4. For the purpose of this exercise, right-click Data Sets and choose JDBC. Alternatively, you can click the yellow database icon to display the JDBC dialog box. The JDBC Data Source dialog box appears.
  5. Under Connections, select SampleData (Hypersonic).
  6. Next to Available Queries, click File:/add.png (Add). Query 1 appears under Available Queries and the edit icon File:/edit.png is now enabled as shown in the following figure:JDBC Data Source Dialog Box
  7. Click File:/edit.png (Edit). The SQL Query Designer window opens. The SQL Query Designer provides you with a graphical environment which allows you to work with the data even if you do not understand SQL, the standard programming language for retrieving content from databases.
  8. Select PUBLIC in the schema filter menu, and then double-click ORDERFACT so that the table appears in the workspace as shown in the following figure:Schema Filter in the SQL Query Designer
  9. In the SQL Query Designer workspace, right-click ORDERFACT and choose deselect all as shown in the following figure:Deselect All Option in SQL Query Designer
  10. Now, select the ORDERNUMBER, QUANTITYORDERED, PRICEEACH, and ORDERDATE fields in the ORDERFACT table as shown in the following figure:ORDERFACT Fields in the SQL Query Designer
  11. Double-click PRODUCTS so that the table also appears in the workspace. Notice the line joining the ORDERFACT and PRODUCTS tables together.
  12. Deselect all the PRODUCTS table fields, and then select just the PRODUCTNAME and PRODUCTLINE fields as shown in the following figure:PRODUCTS Table in the SQL Query Designer
  13. For the purpose of this exercise, click the Syntax tab in the lower left portion of the SQL Query Designer workspace to display a simple SQL statement associated with the tables. Notice that PRODUCTCODE is the common field between the ORDERFACT and PRODUCTS tables as highlighted in the following figure:Syntax Tab with the SQL Query Designer
  14. Click OK in the syntax window to return to the JDBC Data Source dialog box. The SQL statement appears on the right under Query.
  15. Click OK in the JDBC Data Source dialog box. The fields associated with your tables are now under Query 1 as shown in the following figure:Data Tab Showing the Fields in the Query 1 Table

You are now ready to start designing your report