Skip to main content
Pentaho Documentation

Publish Your Report

You have created and formatted a simple report, added a chart, added a parameter, and now you are ready to share the report with your users.

  1. In the Report Designer, click File > Open to open the report you just created.
  2. Click File > Publish. Alternatively, click File:/rd_publish.png. If you have not saved the report, a warning message reminds you to save it. The Login dialog box appears, pre-populated with credentials valid for the evaluation. Make sure that the server's URL is set to http://localhost:8080/pentaho/ as shown in the following example:

Server Login Dialog Box in Report Designer

  1. Click OK. The Publish to Server dialog box appears.
  2. In the dialog box, type in a report title and description into the appropriate fields.
  3. Under Location, save the report in the ...public/Steel Wheels folder.
  4. Select html as the Output Type and click OK. A success message appears.
  5. Click Yes to go directly to the User Console to view the report you just published. If you want to access the report later, log on to the Pentaho Server by going to http://localhost:8080 in a web browser, then navigate to the Reporting Examples directory in the Solution Browser. You should see your published report in the list. If not, click Tools > Refresh Repository.
  6. Log on as Admin. The default admin password is password.
  7. Your report displays in the User Console as shown in the following example:

​​​​​​​Orders Report from the Report Designer in the User Console

  1. In the User Console, select your product line parameter from the drop-down list. Accept the default under Output Type.

You now have a report that users can view at any time.