Skip to main content
Pentaho Documentation

Navigate the PDI Client (Spoon)

PDI Client (Spoon) is a desktop application you install on your workstation enabling you to build transformations and jobs or schedule when jobs should run.

Start the PDI Client

There are a few different ways to start the PDI client. The method that you should use depends on the way you installed Pentaho Data Integration (PDI).

If You Used the Pentaho Installation Wizard to Install Pentaho

If you installed Pentaho using the Pentaho Installation Wizard, you can launch the Pentaho client from your Windows Start menu.

  1. Start the Pentaho Server.
  2. From the Windows Start menu, select All Programs > Pentaho Enterprise Edition > Design Tools > Data Integration. The PDI client, also known as the design tool Spoon, appears.

If You Used Manual Installation to Install Pentaho

If you installed Pentaho using the manual method, you can launch the PDI client from the Pentaho directory.

  1. Start the Pentaho Server.
  2. Navigate to the folder where you have installed PDI. For example ...\pentaho\design-tools\data-integration.
  3. Launch the PDI client in the best way for your operating system. When the Pentaho License Manager dialog appears, you must, at a minimum, enter the Pentaho PDI Enterprise Edition and the Pentaho Hadoop Enterprise Edition licenses to start the PDI client. For more information, see Managing Pentaho Licenses
    1. For Windows: double-click Spoon.bat.
    2. For Linux: double-click spoon.sh
    3. For Macintosh: go to .../pdi-ee/data-integration and double click on Data Integration icon.

Using Perspectives

Pentaho Data Integration (PDI) empowers you with tools that include ETL and scheduling in one unified environment — the PDI client (Spoon) interface. This integrated environment enables you to work in close cooperation with business users to build business intelligence solutions more quickly and efficiently.

When you are working in the PDI client, you can change perspectives to easily switch back and forth from:

  • Designing ETL jobs and transformations
  • Scheduling jobs and transformations

As users provide you with feedback about how the data is presented to them, you can also quickly make iterative changes to your data directly using our data inspection tools in the PDI client.

From within the PDI client, you can change perspectives using the Perspective icon in the toolbar.

Perspectives in PDI help you focus how you work with different tasks.

Data Integration Perspective

The Data Integration perspective allows you to create transformations, jobs, and inspect your data allowing for iterative updates as you work.   

Data Integration Perspective

Component Name Description
File:/grCallout1.png Toolbar Single-click access to common actions such as create a new file, opening existing documents, save and save as.
File:/grCallout2.png Connect Menu Create and connect to repositories for centrally storing your ETL jobs and transformations.
File:/grCallout3.png Sub-toolbar Provides buttons for quick access to common actions specific to the transformation or job such as Run, Preview, and Debug.
File:/grCallout4.png Design and View Tabs

The Design tab of the Explore pane provides an organized list of transformation steps or job entries used to build transformations and jobs. Transformations are created by simply dragging transformation steps from the Design tab onto the canvas and connecting them with hops to describe the flow of data.

The View tab of the Explore pane shows information for each job or transformation. This includes information such as available database connections and which steps and hops are used.

In the image, the Design tab is selected.

File:/grCallout5.png Canvas Main design area for building transformations and jobs describing the ETL activities you want to perform
Table 1. Spoon Icon Descriptions
Icon Description
new.png Create a new job or transformation
open.png Open transformation/job from file if you are not connected to a repository or from the repository if you are connected to one
exploreRepo.png Explore the repository
save.png Save the transformation/job to a file or to the repository
saveas.png Save the transformation/job under a different name or file name (Save as)
Perspectives Menu Switch between the different perspectives.
  • Data Integration — Create ETL transformations and jobs
  • Schedule — Manage scheduled ETL activities on the Pentaho Server

Run transformation/job and set run options; runs the current transformation from XML file or repository
pause.png Pause transformation
stop.png Stop transformation
preview.png Preview transformation: runs the current transformation from memory. You can preview the rows that are produced by selected steps.
debug.png Run the transformation in debug mode; allows you to troubleshoot execution errors
replay.png Replay the processing of a transformation
check.png Verify transformation
impact.png Run an impact analysis on the database
SQLbutton.png Generate the SQL that is needed to run the loaded transformation.
exploredb.png Launch the Database Explorer allowing you to preview data, run SQL queries, generate DDL and more
show-results.png Show execution results pane
lock.png Lock transformation

Schedule Perspective