Skip to main content
Pentaho Documentation

Learn About the PDI Client (Spoon)

PDI Client (Spoon) is a desktop application you install on your workstation enabling you to build transformations and jobs or schedule when jobs should run.

Start the PDI Client

There are a few different ways to start the PDI client. The method that you should use depends on the way you installed Pentaho Data Integration (PDI).

If You Used the Pentaho Installation Wizard to Install Pentaho

If you installed Pentaho using the Pentaho Installation Wizard, you can launch the Pentaho client from your Windows Start menu.

  1. Start the Pentaho Server.
  2. From the Windows Start menu, select All Programs > Pentaho Enterprise Edition > Design Tools > Data Integration. The PDI client appears.

If You Used Manual Installation to Install Pentaho

If you installed Pentaho using the manual method, you can launch the PDI client from the Pentaho directory.

  1. Start the Pentaho Server.
  2. Navigate to the folder where you have installed PDI. For example ...\pentaho\design-tools\data-integration.
  3. Launch the PDI client in the best way for your operating system. When the Pentaho License Manager dialog appears, you must, at a minimum, enter the Pentaho PDI Enterprise Edition and the Pentaho Hadoop Enterprise Edition licenses to start the PDI client. For more information, see Managing Pentaho Licenses
    1. For Windows: double-click Spoon.bat.
    2. For Linux: double-click spoon.sh
    3. For Macintosh: go to .../pdi-ee/data-integration and double click on Data Integration icon.

Use the PDI Client Perspectives

Pentaho Data Integration (PDI) empowers you with tools that include ETL and scheduling in one unified environment — the PDI client interface. This integrated environment enables you to work in close cooperation with business users to build business intelligence solutions more quickly and efficiently.

When you are working in the PDI client, you can change perspectives to easily switch back and forth from:

  • Designing ETL jobs and transformations
  • Scheduling jobs and transformations

As users provide you with feedback about how the data is presented to them, you can also quickly make iterative changes to your data directly using our data inspection tools in the PDI client.

From within the PDI client, you can change perspectives using the Perspective icon in the toolbar.

Updated Perspectives Screen

Perspectives in PDI help you focus how you work with different tasks.

Data Integration Perspective

The Data Integration perspective allows you to create transformations and jobs. See Data Integration Perspective in the PDI Client for more details. You can also inspect your data to make iterative updates as you work.   

PDI_DataIntegrationPerscpective_810.png

In the table below, use the number locators in the preceding illustration to reference the sections and icons on the PDI client. 

Key Feature Description
File:/grCallout1.png Toolbar

Use this toolbar to access common actions: 

  • New file icon (new.png ) to create a new job, transformation, database connection, or slave server.
  • Open file icon ( open.png ) to open a transformation or job from a file. 
  • Explore icon ( exploreRepo.png ) to explore the repository.
  • Save icon ( save.png ) to save the current transformation or job to a file or repository.  
  • Save As icon ( saveas.png ) to save the transformation or job under a different file name or type.
  • Perspectives icon ( ssPDI_PerspectivesMenu.png ) to switch between the different perspectives:
    • Data Integration — Create ETL transformations and jobs.
    • Schedule — Manage scheduled ETL activities on the Pentaho Server. 
File:/grCallout2.png Connect menu Use this button to create and connect to repositories for central storage of your ETL jobs and transformations.
File:/grCallout3.png Sub-toolbar

Use this toolbar to perform transformation or job actions:

  • Run icon ( run.png 9x9_arrow_down.png ) to run a transformation or job:
    • Run —  Runs the current transformation or job from an XML file or a repository.
    • Run Options — Sets the Run Options and then runs the current transformation or job from an XML file or a repository.
  • Pause icon (pause.png) to pause the transformation or job.
  • Stop icon ( stop.png 9x9_arrow_down.png ) to stop the transformation or job: 
    • Stop — Stops the transformation or job immediately.
    • Stop input processing — Stops the input steps to the transformation or job, while allowing any records already retrieved or initiated to be processed and then stopped.
  • Preview icon ( preview.png ) to run the transformation in preview mode to examine the rows produced by the selected steps. 
  • Debug icon ( debug.png ) to run the transformation in debug mode to troubleshoot execution errors. 
  • Replay icon ( replay.png ) to replay the processing of a transformation.
  • Verify icon ( check.png ) to verify the transformation.
  • Analyze icon ( impact.png ) to run an impact analysis on the database.
  • SQL icon ( SQLbutton.png ) to generate the SQL that is needed to run the loaded transformation.
  • Explore DB icon ( exploredb.png ) to launch the Database Explorer to perform actions such as preview data, run SQL queries, and generate DDL.
  • Results icon ( show-results.png ) to show the Execution Results pane.
  • Lock icon ( lock.png ) to lock the transformation. 
File:/grCallout4.png Explore pane

This pane contains the Design and View tabs:

  • The Design tab provides a list of steps or entries that are used to build transformations or jobs.
  • The View tab provides information, such as available database connections and the steps and hops used for the transformation or job.
File:/grCallout5.png Canvas Use the canvas for designing and building transformations and jobs for the ETL activities you want to perform.
 

Schedule Perspective

Customize the PDI Client

The PDI client allows you to customize certain aspects of its behavior, along with the look and feel of the interface. The following table describes each of these options, which can be accessed from the menu bar: Go to Tools > Options, then in the Kettle Options dialog box, select the Look & Feel tab.

Option Description
Fixed width font This option customizes the font that is used in the dialog boxes, trees, input fields, and more; click Edit to edit the font or Delete to return the font to its default value.
Font on workspace This option customizes font that is used in the the PDI client interface; click Edit to edit the font or Delete to return the font to its default value.
Font for notes This option customizes the font used in notes that are displayed in the PDI client; click Edit to edit the font or Delete to return the font to its default value.
Background color This option sets the background color in the PDI client and affects all dialog boxes; click Edit to edit the color or Delete to return the background color to its default value.
Workspace background color This option sets the background color in the graphical view of the PDI client; click Edit to edit the background color or Delete to return the background color to its default value.
Tab color This option customizes the color that is being used to indicate tabs that are active/selected; click Edit to edit the tab color or Delete to return the color to its default value.
Icon size in workspace Affects the size of the icons in the graph window. The original size of an icon is 32x32 pixels. The best results (graphically) are probably at sizes 16,24,32,48,64 and other multiples of 32.
Line width on workspace Affects the line width of the hops in the the PDI client graphical view and the border around the step.
Shadow size on workspace If this size is larger than 0, a shadow of the steps, hops, and notes is drawn on the canvas, making it look like the transformation floats above the canvas.
Dialog middle percentage By default, a parameter is drawn at 35% of the width of the dialog box, counted from the left. You can change using this option in instances where you use unusually large fonts.
Canvas Grid Size Indicates the size of the grid on the PDI client canvas.
Show Canvas Grid Enabling this option will show a dotted grid on the PDI client canvas.
Canvas anti-aliasing Some platforms like Windows, OSX and Linux support anti-aliasing through GDI, Carbon or Cairo. Enable this option for smoother lines and icons in your graph view. If you enable the option and your environment does not work, change the value for option "EnableAntiAliasing" to "N" in file $HOME/.kettle/.spoonrc (C:\Documents and Settings\<user>\.kettle\.spoonrc on Windows).
Show bottleneck transformation steps If a step in the transformation is processing slowly, a graphic displays around that step to make the bottleneck visible.
Use look of OS Enabling this option on Windows allows you to use the default system settings for fonts and colors in the PDI client. On other platforms, the default is always enabled.
Show branding graphics Enabling this option will draw Pentaho Data Integration branding graphics on the canvas and in the left hand side "expand bar."
Preferred Language Specifies the preferred language setting.
Alternative Language Specifies the alternative language setting. Because the original language in which Pentaho Data Integration was written is English, it is best to set this locale to English.