Skip to main content

Pentaho+ documentation has moved!

The new product documentation portal is here. Check it out now at docs.hitachivantara.com

 

Hitachi Vantara Lumada and Pentaho Documentation

spec

pentaho.data.filter. spec

The filter.spec namespace contains specification interfaces for filters.

Source: doc-js/pentaho/data/filter/spec/_namespace.jsdoc, line 17

Interfaces

Name Summary
IAbstract

The spec.IAbstract interface describes the information associated with a filter.

IIsEqual

The spec.IIsEqual interface describes the information associated with an equality filter.

IIsGreater

The spec.IIsGreater interface describes the information associated with a is greater filter.

IIsGreaterOrEqual

The spec.IIsGreaterOrEqual interface describes the information associated with a is greater or equal filter.

IIsLess

The spec.IIsLess interface describes the information associated with a is less filter.

IIsLessOrEqual

The spec.IIsLessOrEqual interface describes the information associated with a is less or equal filter.

IIsLike

The spec.IIsLike interface describes the information associated with an is-like filter.

INot

The spec.INot interface describes the information associated with a negation filter.

IProperty

The spec.IProperty interface describes the information associated with a property filter.

ITree

The spec.ITree interface describes the information associated with a tree filter.